Required dependencies

SSHD has 2 compile-time dependencies:

  • MINA Core 2.0.x :
  • SLF4J API 1.6.4 :

Note that since SSHD 0.9.0, the Mina Core library is optional when running in JDK 1.7 and SSHD will default to using nio2 if available.

To be able to run SSHD, you will also need one SLF4J Logger implementation. The simpliest one is the one using java.util.logging underneath which can be downloaded at